Some UMassOnline Blackboard Sites Unavailable
Incident Report for UMassOnline
Resolved
The incident has currently been resolved. Blackboard engineers are monitoring the system health at this tome.
Posted Oct 16, 2019 - 18:09 EDT
Identified
The issue has been identified and fix is being implemented.
Posted Oct 16, 2019 - 17:26 EDT
This incident affected: UMass Dartmouth Blackboard Learn.